Enable jQuery Migrate Helper

Description

With the update to WordPress 5.5, a migration tool known as jquery-migrate will no longer be enabled by default. This may lead to unexpected behaviors in some themes or plugins who run older code.

This plugin serves as a temporary solution, enabling the migration script for your site to give your plugin and theme authors some more time to update, and test, their code.

Installation

  1. Upload to your plugins folder, usually wp-content/plugins/.
  2. Activate the plugin on the plugin screen.
  3. That’s it! The plugin handles the rest automatically for you.

FAQ

What does it mean that something is “deprecated”

A script, a file, or some other piece of code is deprecated when its developers are in the process of replacing it with more modern code or removing it entirely.

How do I find and use the browser console

www.4f19.cn has an article about using the browsers console log to diagnose JavaScript errors.

Reviews

September 21, 2020
Good working fix for a few scripts in obsolete themes/plugins. Thank you!
September 16, 2020
I too have discovered a legacy plugin that relied on deprecated functions in Migrate. Thanks for making a patch available for an interim solution.
September 15, 2020
Logged in just to say thanks for the plugin. Fixed three of my legacy themes. Huge time-saver.
Read all 72 reviews

Contributors & Developers

“Enable jQuery Migrate Helper” is open source software. The following people have contributed to this plugin.

Contributors

“Enable jQuery Migrate Helper” has been translated into 12 locales. Thank you to the translators for their contributions.

Translate “Enable jQuery Migrate Helper” into your language.

Interested in development?

Browse the code, check out the SVN repository, or subscribe to the development log by RSS.

Changelog

v 1.0.1

  • Fix one of the admin notices being non-dismissible.

v 1.0.0

  • Initial release.